Back to overview
Resolved

Application Update

Jun 27, 2026 at 6:45am UTC  –  Jun 27, 2026 at 9:00am UTC
Affected services
Web App
Workspaces
Workflows
Deliverables
Accounts
KOPE Market
Marketplace API

Resolved
Jun 27, 2026 at 9:00am UTC

Maintenance ended

Created
Jun 27, 2026 at 6:45am UTC

Significant update to product and underlying infrastructure